HELP fatal error when trying to generate font

Discussion started on Other Topics

Hello all,
when I try to generate the Opentype PS fontlab gives me this error:

"[FATAL] Some glyphs used in feature file were not found in the font"

BUt, more often, it just crashes. What can I do? I'm using Fontlab studio 5.1.2 on a Mac OS X 10.7.5

Thank's a lot to everybody that could help me
#1 - 2015-05-20, 11:06

1. Update to FontLab Studio 5.1.4 ( http://old.fontlab.com/downloads/Installers/FLS5MacFull.dmg )

2. Open the Panels / Classes panel, click on the panel menu button and choose "Clean Up Classes", then "OK". You will get a dialog that will tell you which glyphs are "missing". By "missing", it means that one of the classes in the Classes panel is referring to a glyph (by name) that does not exist. The dialog box will allow you to either remove the "missing" glyph names from the classes, or add these glyphs to the font.

3. Open the Panels / OpenType panel, and click on the "Compile" button. In the Output panel, you will get a list of entries "Missing glyph: xxxx", where xxxx is the name of a glyph that is referenced in your feature definitions (in the OpenType panel). Either add the glyph(s) which have those names, or find the place in your feature definitions where the glyph(s) are referenced, and remove them (i.e. rewrite that portion of the feature definition).

4. Hit "Compile" until there are no errors. Then generate the font.
#2 - 2015-05-20, 19:10
Regards,
Adam Twardoch
Fontlab Ltd.

to learn more, I invite to This is my page.

vip2541
#3 - 2018-09-16, 23:58

Members:

0 Members and 1 Guest are viewing this topic.