FLS 5.1.6 - a new clipboard bug

Discussion started on FontLab Studio 5

First, thanks for the FontLab update. Although the clipboard bug has been largely fixed, I notice that copy and paste no longer works in the opentype panel.
#1 - 2019-04-04, 10:45

Support+Docs, FontLab
Did that work in 5.1.5?
#2 - 2019-04-04, 10:50
Although we do try to track bug reports in the forums,
a much more reliable route is to use our bug report
form at support.fontlab.com

CEO, FontLab
Yuri is taking a look at it.
I *think* it worked in 5.1.5.
#3 - 2019-04-04, 11:06

It definitely worked in previous versions.
#4 - 2019-04-04, 11:27

Vice-president, FontLab
actually you can copy from the feature text, it is paste that is not working.
#5 - 2019-04-04, 17:07
Regards,
Yuri Yarmola

Yuri, can you paste that copied text into a text editor, then copy it from there and paste back into Fontlab window?  It may not be copy, it just may be paste.
#6 - 2019-04-04, 20:09
ChrisL

Vice-president, FontLab
in any case, we decided to fix this little but annoying problem, please wait for announcements.
#7 - 2019-04-05, 17:31
Regards,
Yuri Yarmola

THANKS!
#8 - 2019-04-06, 10:21
ChrisL

If I copy and paste a feature definition into the OT panel, the last semicolon and the [CR] after it get lost. Is that the bug we're talking about?
#9 - 2019-05-28, 13:20

No — that bug was introduced when they fixed the earlier bug which prevented pasting at all. I never bothered to report it since it is comparatively minor.
#10 - 2019-05-29, 06:04

Thomas:
There's still a bug when copying and pasting in the OpenType panel. :-[

If you copy and paste a complete feature, the last semicolon and CR get dropped.

If you copy and paste a single line, the last character in the line and the semicolon get dropped.

Just sayin'...

But thanks for the fixes. FontLab is back on my Christmas card list.

#11 - 2019-06-05, 14:15

Members:

0 Members and 1 Guest are viewing this topic.